Why does the Url get encoded even when all other settings about Url encode are disabled

so I have a http request in the config and suppose it has ?id=<input.MAIL>|<input.PASS> in the Url.
I have the encode content option unchecked and also have the encode data after slicing option unchecked in config settings but still it encodes the Url before sending.
the | is encoded to %7C.
I don’t want it to beUrl encoded!

URL encoding in the query (GET parameters) is enforced at all times currently. If you want open an issue on github