SSL Connection Problem

I’m getting SSL connection problem. This is the first time I have to deal with it. I’m using Linux (arch) as operation system and using OB2 by hosting it through localhost and never had this issue before. I’m experiencing this error while trying to check into this website:

I have already tried all security protocols and both http libraries. Something interesting is, that burp suite request works perfect, but when doing through OB I get rigged because of the SSL.

This is the exact error:


The SSL connection could not be established, see inner exception.

You can enable verbose mode in RL settings, do that and see if the exception tells you more about what happened.

This is the output:

[Executing block Http Request] ProxyException: RuriLib.Proxies.Exceptions.ProxyException: Failed SSL connect
at RuriLib.Http.RLHttpClient.CreateConnection(HttpRequest request, CancellationToken cancellationToken)
at RuriLib.Http.RLHttpClient.SendAsync(HttpRequest request, Int32 redirects, CancellationToken cancellationToken)
at RuriLib.Functions.Http.RLHttpClientRequestHandler.HttpRequestStandard(BotData data, StandardHttpRequestOptions options)
at Submission#0.<>d__0.MoveNext()
— End of stack trace from previous location —
at Microsoft.CodeAnalysis.Scripting.ScriptExecutionState.RunSubmissionsAsync[TResult](ImmutableArray1 precedingExecutors, Func2 currentExecutor, StrongBox1 exceptionHolderOpt, Func2 catchExceptionOpt, CancellationToken cancellationToken)
at Microsoft.CodeAnalysis.Scripting.Script1.RunSubmissionsAsync(ScriptExecutionState executionState, ImmutableArray1 precedingExecutors, Func2 currentExecutor, Func2 catchExceptionOpt, CancellationToken cancellationToken)
at Microsoft.CodeAnalysis.Scripting.ScriptStateTaskExtensions.CastAsync[S,T](Task`1 task)
at RuriLib.Models.Debugger.ConfigDebugger.Run()

Are you using proxies?
If not, can you try to manually select the TLS version from the security protocol dropdown in the HttpRequest block?

I’m not using any proxy, and already tried with the TLS versions. I tried with few public IP:PORT to see if was giving same error, and they do. Idk if it has something to do with Linux, but will check lately in windows. Just wondering if there were any solution already to it.