Compiling my own build error

Hey, when I compiling my own build without some changes and open my localhost page I don’t get the full setup and images are missing.
In the cmd box i see this error:

Error: Could not find ‘startRandomSetupEffect’ (‘startRandomSetupEffect’ was undefined).

fail: Microsoft.AspNetCore.Components.Server.Circuits.CircuitHost[111]

Any ideas?

1 Like

You need to publish not build (in Release mode). Then go to bin/Release/net5.0/publish and you’ll find the build there.

I fixed my guide, thanks for letting me know


Thanks Ruri I had the same problem. one question do you plan to add a search engine when looking for configuration? the truth is that it makes a little heavy to search when you have many configurations. Thanks.

At the top click on “toggle view” to get to the table view and then set a filter on the config name column

I downloaded it and compiled it yesterday following Ruri’s guide. I have gotten some errors but it works fine. I love ob2 although it is only beta it is wonderful.

1 Like

I’ve got the same problem. I am following the official guide, everything is good but get the same error and the page is broken. And, the weird thing is, it sometimes works, but sometimes not. I’ve cloned my fork and built it, and it didn’t work for some reason, but yesterday I did the same thing and it worked, can’t figure out what I did different.

Well, I figured it out 1 minute after this message. For me it turns out I need to launch it using dotnet bin\Release\net5.0\OpenBullet2.dll while being in OpenBullet2\OpenBullet2 directory. I have no idea why, but it worked like that.

Nevermind, looks like I was just launching it wrong and there weren’t any problems with anything else.