Bypass Cloudflare Cookie Block

Hello to whom reads this,

I’m currently using RuriLib’s HTTP fork library, but have came across an issue with a service that blocks their API with Cloudflare. The response says to enable cookies, but I’m sure the library automatically does this. Is there any way to bypass this, it isn’t a JS challenge/recaptcha block.


Access denied | used Cloudflare to restrict access
Please enable cookies.

Error 1020

Ray ID: [redacted] • 2022-01-25 08:13:26 UTC

Access denied

  <section class="w-240 lg:w-full mx-auto mb-8 lg:px-8">
      <div id="what-happened-section" class="w-1/2 md:w-full">
        <h2 class="text-3xl leading-tight font-normal mb-4 text-black-dark antialiased" data-translate="what_happened">What happened?</h2>
        <p>This website is using a security service to protect itself from online attacks.</p>


  <div class="cf-error-footer cf-wrapper w-240 lg:w-full py-10 sm:py-4 sm:px-8 mx-auto text-center sm:text-left border-solid border-0 border-t border-gray-300">

Cloudflare Ray ID: [redacted] Your IP: [redacted] Performance & security by Cloudflare

</div><!-- /#cf-error-details -->

I don’t know of any free and public way to bypass cloudflare currently.

It was a header that was being picked up by Cloudflare’s anti-bot. I fixed it now, thank you for the reply.


If you have time, please share with me some feedback regarding the library, I am really interested to hear from people who actually use it :sweat_smile:


Tell us how u did it bruh that help the community and ruri to creat the best stable version of OB2 and Thank You in advance

This library is honestly a godsend. It’s the best fork of xNet I’ve used in a long time since I’ve gotten back into programming lately. Although with a NoProxyClient it shouldn’t be required to have a ProxySettings parameter unless there is a special use for it. Other than that, I don’t really have another complaints

1 Like

It was just a referrer header that I was sending incorrectly so CloudFlare was acting up and blocked my request. I fixed it to the proper value and now it sends the request with no issue. I’m going to be creating a code generator that takes HTTP requests and converts it to RuriLib.Http code soon, but no hard date.