Why my OB2 Crashes on Linux VPS after uploading Wordlist?

Hello,
Please somebody help me, after successfully making OB2 live on my linux (centOS) VPS, it crashes out. It crashes only when I try to upload wordlist. It crashes saying “Segmentation fault” on my terminal. After crash i need to reopen it and make it live again using “dotnet ./OpenBullet2.dll” command.

IMAGE link: Screenshot by Lightshot
Rightnow my OB2 is live on: http://454fdda1599e.ngrok.io/ (I reinstall again without uploading wordlist)

Please somebody help me here.

Are you sure it has enough RAM to process the wordlist you uploaded? There is another way to add wordlists, without uploading them through the browser, simply send the wordlist to the server using scp and then use the file system option in the “Add Wordlist” modal, search for the list on the local filesystem and use it directly. Otherwise make sure permissions are okay or try running with sudo, I don’t know what else to say because it worked on every linux installation I tried :confused:

If you are able to get another OS for your VPS, try ubuntu server, never had a problem with it!

I already uploaded using the filesystem method too… but same error. I just ran OB2 with sudo command and try uploading wordlist … again same error, OB went down. My system has ram of 5944480 kB . I dont think memory is problem because memory usage is very low. Maybe OB dont work on centOS.
Should I need to chmod “wordlist” folder too? Haven’t done that. If you dont mind i will give you the vps access sir?

Yeah maybe try to chmod it, sure. I don’t think I will be able to debug this myself even if you give me access honestly, there is no information about the error whatsoever, segfault is one of the worst things to debug :frowning: you cannot switch to ubuntu?

Otherwise try to use it inside docker, that will probably work just fine :slight_smile:

ok I will try to chmod every user /files folder … or use Docker and let you know. If that donot work then i will mail you the credentials. And if that too wont work then ofcourse i need to install ubuntu XD.

But it would be best if OB run on centOS too XD.

I’m sure docker works since it acts as a lightweight VM where it runs on Alpine Linux.
Are you completely sure you installed the proper version of the asp.net core runtime btw? Because they have various guides for every OS, did you follow the guide for CentOS/RedHat?

yeah I followed the guide for cent OS. Even checked my version before installing… it has “centOS v7”, and installed dotnet following guidelines for that version. I will let you know … using Docker now. Thanks again :slight_smile:

Finally somehow I manage to install Docker … everything works fine OB2 seems to be working.
I used the following command

 sudo docker run --name openbullet2 --rm -p 8069:5000 -v /home/USERNAME /public_html/.boot/www/OB2/UserData/:/app/UserData/ -it openbullet/openbullet2:latest

OB2 seems to work … it says => Now listening on: http://[::]:5000

Then I start a HTTP tunnel forwarding local port 8069 using ngrok

./ngrok http 8069

everything seems to work

but after visiting the URL given by ngrok it gives error on my browser saying

ngrok gateway error
The server returned an invalid or incomplete HTTP response.

:frowning: damn so close and still got an error. is there port mismatch or sth else sir?
OB says Now listening on: http://[::]:5000 I think it should be Now listening on: http://localhost:5000 ??? @_[email protected]??

No it’s correct like that, it says listening on localhost only if you want to be able to access OB2 from the same machine (a.k.a from inside the docker container itslef) but here you’re accessing it from the host system so it needs to be accessible on all interfaces, the command is correct and you’re getting the correct message.
Have you tried opening port 8069 on the CentOS machine and simply accessing

http://centos-ip:8069

from the other computer?

Wow I cannot believe it worked like a charm. How silly of me to forget about my own VPS IP. Tried tunneling on ngrok and cloudflared … no use literally wasted my time like 6 hours… You should have replied sooner XD. Thank you very very much.
Also now I can upload “Wordlist” as much as I want. It worked and no crash this time. Though Installing Docker was pain in the neck for me, But it paid off.
Also one more thing can I delete the installed dot net package of microsoft … to save space ? I think Docker already has it inside its container or sth like that?
Thanks again Ruri.

Yep you can definitely delete it, docker has everything inside it.
Npnp good luck for the future

1 Like