Openbullet2 on Mac M1. Does it work?

Does openbullet2 run on MacBook M1 running Monterey Beta?

I’m pretty sure it does run anywhere .NET 5 is supported.

I get an error each time i run. Installed runtime 5.4.

It would be really cool if you posted the error :slight_smile:

This is what I get each time

It means port 5000 is already in use, maybe you already opened one or you have some other service running on the same port. Please use a different port, you can configure it by using this command

dotnet ./OpenBullet2.dll --urls=http://*:8080

where 8080 is the desired port

used --urls=http://localhost:8080 and it works now!!!

Thanks!

1 Like

can you help me put ob2 on my Mac having issues

It would be helpful if you described those issues, what is happening?

do you have a telegram I can reach you at or discord

Screen Shot 2022-03-03 at 8.18.30 PM

I’ve done bullcrap trying to fix, but the problem is when I try to open the dll it always says denied

I see multiple things that are not ok.

1 Like

when he fix ob2 can help me!!!

Update: 0.2.3 will include the fix.
grafik
BTW: it will still need to allow sqlite3 in Security preferences of your mac after first try to start. But after that ob2 should work (maybe you need also to use an other port - as i did. Cause Airplay sits on Port 5000)

Can you give step by step how to put on Mac book or assist me, and u said update when will it be released

It is already out since a few minutes after my posting.

Just follow the guide ruri made for mac/linux but you get an error with sqlite3 on first start. So just do it like opening any other app from an unidentified developer.
And ofc look above or at my screeenshot for the parameter for opening it on an other port if you haven’t switched off the Airplay receiver on your mac.

bro its not working please help me on team viewer