how do you run ob2 on mac os?

when i try to start ob 2 on mac os it gives me this error: unhandled exception. system.io.filenotfoundexception: the configuration file ‘appsettings.release.json’ was not found and is not optional.
PLS HELP ME

try to make this file with this settings

{

“AllowedHosts”: “*”,
“urls”: “http://0.0.0.0:5000
}

Not working with your settings

1 Like

It give me this error : Unhandled exception. System.IO.FileNotFoundException: The configuration file ‘appsettings.Release.json’ was not found and is not optional. The physical path is ‘/Users/crackermaster/appsettings.Release.json’.
at Microsoft.Extensions.Configuration.FileConfigurationProvider.HandleException(ExceptionDispatchInfo info)
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load(Boolean reload)
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load()
at Microsoft.Extensions.Configuration.ConfigurationRoot…ctor(IList`1 providers)
at Microsoft.Extensions.Configuration.ConfigurationBuilder.Build()
at Microsoft.Extensions.Hosting.HostBuilder.BuildAppConfiguration()
at Microsoft.Extensions.Hosting.HostBuilder.Build()
at OpenBullet2.Program.Main(String[] args) in C:\Users\scarf\source\repos\OpenBullet2\OpenBullet2\Program.cs:line 34
Abort trap: 6

Did U put this file inside OB folder?

are You trying to build Your own ob? Why not to try download release?

Yes bro with name appsetting.relase.json

No i trying to open a open bullet 2

did U install asp netcore?

yes but not the binaries

how do i install this?

@Ruri pls bro help me

There are plenty of guides on the web, just find one

I can’t find a suitable one , what is the problem causing that error ? @Ruri

It’s literally telling you that it cannot find a certain file, so maybe check if the file is present? Maybe it didn’t get extracted properly?

check and let you know, thanks

nothing to do the mistake persists
i remember i am trying to start it on mac os
i use this command to start dotnet /Users/crackermaster/Downloads/OpenBullet2/OpenBullet2.dll

Maybe navigate to the correct folder first and then launch the dll, see if it helps