Dotnet uses 100% of CPU in RPi 4

Hello everyone. I’m using OB2 (v. 0.1.21) in portainer with a RaspberryPi 4 8GB, when it’s in use the service dotnet uses more than 100% of CPU, is it a normal behaviour or there’s something wrong? I know it using the command “top” in terminal. Thanks

I’m pretty sure the raspberry pi doesn’t have the best specs, and running a server-side UI like blazor is pretty resource intensive. Have you considered using the CLI version instead?

With the previous versions my CPU load didn’t reach more than 3 in 1 minute (I check it with RPi-Monitor), now with this new version it arrives even at 20. I don’t know how to roll back to the previous version to see if it’s my problem or OB2 problem, since on docker.hub there’s only the latest version

Edit: I’ve noticed that the service “kswapd0” uses around 90-100% of CPU when OB2 is working, and that’s another problem causing the increase loading of CPU.

We could start versioning docker containers too, maybe open an issue on github and we will try to add it to the build pipeline. As of now, the only thing you can do is wait or build another docker image yourself.

Done. Thank you. I’ve edited the previous post, is it useful somehow?

1 Like

It seems it was a kernel problem related, and I think I’ve fixed it. Dotnet still uses more than 100% of CPU but at least kswapd0 is silent. I hope that with the next versions of OB2 dotnet could use less power. Thanks for your help

100% ? i run 1 job to 10 threads check the result
https://ibb.co/2KhTN7y

but i cant copy data https not working :confused: